
 
 

 

QUICK GUIDE: HOW TO CREATE MEDIA FILES FOR THE ESPRECIOUS 
 

 
This quick guide explains you –in a few steps– how you can create media files for the Esprecious. Appendix 1 
shows how you can import the media files into the Esprecious. Note! You need an SD card to import media files. 
 
You can change and import four different sorts of media files: 
1. Beverages 

The Esprecious shows eight beverage images as the machine can serve up to eight beverages. You can 
change the cup/mug images that Bravilor Bonamat supplies as standard yourself. A compressed ZIP file with 
all standard PNG cup/mug images is available on request ‘PNG files of beverages’. 

2. Screensaver: image 
You can change the image of the screensaver that appears after 3 minutes (if the machine is not in use and 
the screensaver mode is activated). 

3. Background 
You can change the background image. The background image is visible behind the cups/mugs in the 
main menu. 

4. Screensaver: video (with audio) 
You can convert an existing video to a smaller format so that the Esprecious can play it as screensaver video. 
The screensaver video appears after 3 minutes (if the machine is not in use and the screensaver mode is 
activated). 

 
Note! You need an SD card to import new media files into the Esprecious. 
 
 

1. BEVERAGES 
 
The specifications of each beverage image need to be: 

- PNG file with a transparent background. 
- 295 width x 210 height pixels. 

 
Get started 

- Bravilor Bonamat can send you a compressed ZIP file ‘PNG files of beverages’. This ZIP file contains all 
the beverage images (cups/mugs) that are being used by the machine as standard. These images already 
meet the above mentioned specifications. We recommend you to use the PNG files as starting point. 

 
- Then, you can add your company logo or coffee brand to the PNG files. Just make sure that the 

background remains transparent whilst saving the file. Therefore we advise you to use Adobe Photoshop 
or a similar photo edit programme. Make sure to save the files as PNG files. 

 
- Some customers might already have their own photography with branded cups/mugs and their own logo. 

In that case, just make sure that the images have a transparent background and meet the specifications as 
mentioned above. 

 
- When you save the PNG files make sure to keep the name of the file simple, like coffee, cappuccino, 

espresso, etc. Save the files onto your SD card. 
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2. SCREENSAVER: IMAGE 

 
The specifications of the screensaver need to be: 

- JPG or PNG file. This media file does not need a transparent background. 
- 600 width x 950 height pixels. 
 

Get started 
- Create one image. For the screensaver you can use a simple photo edit programme, like Paint.  

If you would like to use Paint, follow the following steps. 
 
- Go to Paint (click on the Windows button at the bottom/left, choose: All Programs, Accessories and Paint) 

o Click on Resize 
o Select Pixels 
o Fill out Horizontal = 600 (make sure it says Pixels not Percentage!) 
o Fill out Vertical = 950 
o Click on OK 
o Now you have created a basic white screensaver with the right specifications. 
o Now you can copy and paste your preferred image(s), design or logo. 
o When you are ready developing your screensaver, choose Save as and JPG (use a short name, 

like Screensaver). Save the screensaver onto your SD card. 
 
 

3. BACKGROUND 
 
The specifications of the background image need to be: 

- PNG file with a transparent background or JPG with a (dark) colour. 
- 600 width x 1024 height pixels. 
- We highly recommend you not to use a light colour or white. If you use a light coloured background you 

will not be able to read the beverages and/or see the white cups/mugs. 
 

Get started 
- Create one image. You can use Adobe Photoshop to create a transparent background (vector) image 

or you can use Paint to create a coloured background image. In that case, see point 2 above. 
Please make sure that the background image is not white! 

 
- If you would like to use Adobe Photoshop, follow the following steps. 
- Go to Adobe Photoshop. 

o Click on File 
o Click on New 

§ Name: Background 
§ Width: 600 pixels 
§ Height: 1024 pixels 
§ Resolution: 72 pixels/inch 
§ Color Mode: RGB Color 8 bit 
§ Background contents: Transparent 

o Click on OK 
o Now you have created a basic transparent background with the right specifications. 
o Now you can copy and paste your preferred image(s) or logo in the background. 
o When you are ready developing your background, choose File in the upper toolbar. 
o Choose Save As (File name = Background). 
o Make sure that the Save as type is PNG then click on Save. Save the background image onto 

your SD card. 
 
 
How to actually import the beverage images, screensaver image and background into the Esprecious >> 
see appendix 1. 
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4. SCREENSAVER: VIDEO (WITH AUDIO/SOUND) 

 
The right specifications of a screensaver video depend on various values and settings such as sound 
(or no sound), the quickness of the moving images and the animation itself. 
 
We use the below specifications as guideline. However this can vary per video. Depending on the video the frame 
and bit rate need to be set higher or lower. We see it as learning by doing. You can keep adapting the 
specifications until you are satisfied with the result (and/or synchronous music/sound). 
 

 Size (pixels) Frame-rate 
(f/s) 

Video bit rate 
(kb/s) 

Audio bit rate 
(kb/s) 

File format 

Video 600 x ca. 340 (wxh) 15-24 < 400 - MPEG-4 
Video with audio/sound 600 x ca. 340 (wxh) 15 < 350 64 MPEG-4 
Slide show (full screen) 600 x 1024 (wxh) < 1 400 16 MPEG-4 
 
The below steps are based on Adobe Premiere. Bravilor Bonamat works together with an agency for its Esprecious 
videos. We can ask this agency to make the proper adjustments to your existing video if required. 
 
It is also possible to download a 30-day free trial of Adobe Premiere, see 
https://creative.adobe.com/en/products/download/premiere 

 
Getting started 

- Open Adobe Premiere. 
- Create a new project. 
- Change the file name and location. Note! Do not use white spaces in the file name! 

 
- Menu: → Window → make sure that the following windows are ticked off: 

o Effect Controls 
o Program Monitor 
o Project 
o Timeline 

You need those windows to do the following steps. 
 

- Menu: → File → Import... and select your video in the browser. 
 

- Drag the imported video from the window Project to the window Timeline. 
The video is now ready to be edited. 
For your information: In the window Program you can press play and run the video. 
Now we need to change the format of the video. 
 

Rotate the video and change the dimensions 
- Menu: → Sequence → Sequence settings 

Change the size to Frame Size: 338 horizontal, 600 vertical 
 
Note: the video in the Esprecious will be rotated automatically. Therefore the values need to be filled out 
vice versa. The max width of the display is 600 pixels (so 600 needs to be filled out at vertical) and the 
height of the video (with screen 16:9) will be approx. 338 pixels. This number needs to be filled out at 
horizontal. 
 

- Double click in the window Program on the video (this can be a black screen). 
The video will be activated in the window Effect Controls. 

 
- Select the window Effect Controls. Click in the window on the tab of the correct video. Change the below 

values: 
o Video Effects → Motion → Rotation: 270° 
o Video Effects → Motion → Position: 169 and 300 (= Centre of ‘test’ video) 
o Video Effects → Motion → Scale: make sure that the black screen is fully filled (in this case 94) 
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In the window Program you can press Play to run the video. 
The video needs to run 90ºC counter clockwise and fully filled. If you still see black borders the scaling 
process did not go 100% right and adjustments need to be made. 
 

Save: How do I export the video to MPEG-4 format? 
- Select the window Program or Timeline 
- Menu: → File → Export → Media 

For your information: The export menu opens. Change the below settings. 
The values of the bit rate can be seen as a guideline. The numbers will change per video to get the best 
result. In case of the ‘test’ video these are the correct settings. 
 

o Export Settings – Format: H.264 
o Export Settings – Preset: Custom 
o Export Settings – Output Name: company-video (note that the file name cannot have white 

spaces!) 
o Export Settings: Tick the square Video (and Audio if applicable) 

 
- Select the video tab in the menu under Export Settings and change the following values/settings: 

o Basic Video Settings – Frame-rate: 15 
o Bit rate Settings – Bit rate Encoding: CBR 
o Bit rate Settings – Target Bit rate [Mbps]: 0,35 

 
- Select the audio tab (only applicable if the square Export Settings has been ticked off at audio). Change 

the below values/settings: 
o Audio Format Settings – Audio format: AAC 
o Basic Audio Settings – Audio Codec: AAC 
o Basic Audio Settings – Channels: mono 
o Bit rate Settings [kbps]: 64 

 
For your information: The guideline for the total target bit rate (video and audio together) is less than 0,4 Mbps 
(as is the case in the ‘test’ video). If the quickness of the video is still to slow or if the video and audio are not 
matching the total bit rate needs to be reduced. How more complicated the video, how lower the bit rate must 
be to get a proper video. If the bit rate is so low that the quality of the video itself gets pour, you might consider 
exporting the video without audio/sound. 

 
How do I save the video on an SD card ensuring it runs automatically on the Esprecious 

- The video or slide show must be MPEG-4. 
- The file name cannot contain white spaces. 
- The video must be saved in a folder on the SD card called screensavervideos. 
- The SD card must stay in the Esprecious as the machine runs straight from the card. 
- Make sure that the screensaver mode has been activated (see appendix 2). 

 
If you use a video screensaver we advise you to also create a screensaver image (point 2) and import that media 
file to the Esprecious. The screensaver video and image will appear at the same time after 3 minutes. 
 
Please contact Bravilor Bonamat for more information +31 (0)72 575 1751 or e-mail sales@bravilor.com. 
 
Bravilor Bonamat BV 
 
To see some examples of media files, please ask your Bravilor Bonamat contact person to send you this file: 
‘Files screensavers, backgrounds and video’. 
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Step 1

Step 7

• Open the front panel door 
with the key.

• Insert the SD card with 
your new media files.

• Press the black P button.

When you changed the 
images, you see that the 
thumbnails have changed.

These are the images that 
will show in the main menu.

• Click on the < symbol.

• Click on Service.

• Click on the house symbol 
to go back.

• Click on SD card.

• Click on the red arrow to 
go back.

Now you see thumbnails of 
all the current media files.

• Click on the button of the 
item you would like to 
change. 

Now you see the files that 
you have placed on your 
SD card. 

• Select the media file you 
would like to add. It takes 
a couple of seconds to 
adjust the settings.

To go back to the original 
media files follow step 1-4. 

• Select the button Back to 
the original media files.

And follow step 7-9.

• Click on Import media 
files.

Note that if you have not 
inserted the SD card 
(properly), this button 
cannot be selected.

Now you see the new
interface that you have 
created:
• new background
• new beverage images

The Esprecious is ready to 
serve coffee again.
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Step 10

Step 5

Step 11

Step 6
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Step 1

Instructions to turn the screensaver mode ‘ON’.

• Open the front panel door 
with the key. 

• Press on the black 
P button.

• Click on Machine Settings. • Click on General Settings. • Make sure the 
Screensaver is ON.

• Click on Put functions 
ON/OFF.

Step 2 Step 3 Step 4 Step 5
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